Elite Suito - Not showing cadence while on Bluetooth

A virtual coach compatible with all Elite hometrainers

Moderators: Elite Admin S, Elite Admin M

mannypalombi
Posts: 1
Joined: Fri Oct 11, 2019 2:13 am

Elite Suito - Not showing cadence while on Bluetooth

Postby mannypalombi » Fri Oct 11, 2019 2:15 am

I set up my Elite Suito and everything works fine and connects
Issue is that it shows speed and power, plus provides resistance. It does not show cadence?

I tried on iPhone 11, iPad and Mac.

If I connect it to my Garmin (via ant plus ) everything works fine.

I only have this issue on Bluetooth.

Any suggestions?

hug777
Posts: 2
Joined: Tue Nov 05, 2019 5:24 am

Re: Elite Suito - Not showing cadence while on Bluetooth

Postby hug777 » Tue Nov 05, 2019 5:24 am

I have the Same problème! Do you find solutions?

hug777
Posts: 2
Joined: Tue Nov 05, 2019 5:24 am

Re: Elite Suito - Not showing cadence while on Bluetooth

Postby hug777 » Tue Nov 05, 2019 5:27 am

I don’t understand that’s the app for that product and it doesn’t work ?

simon.murray
Posts: 1
Joined: Fri Jan 03, 2020 3:00 pm

Re: Elite Suito - Not showing cadence while on Bluetooth

Postby simon.murray » Fri Jan 03, 2020 3:04 pm

If your cadence sensor is Ant+ only (my Garmin one is) you can’t connect it to the app via Bluetooth. You need a separate Ant+ dongle which really would only be used with a computer. When you initially configure your Suito don’t select an external cadence sensor and instead it will use the in-built cadence calculator. It works just as well. I had the same issue and this is how I resolved it. Hope that helps.


Return to “My e-training Mobile”

Who is online

Users browsing this forum: No registered users and 2 guests