Using battery in only 2-4 hours

Moderators: Elite Admin S, Elite Admin M

spenorden@gmail.com
Posts: 2
Joined: Mon Mar 25, 2019 2:20 pm

Using battery in only 2-4 hours

Postby spenorden@gmail.com » Mon Mar 25, 2019 2:29 pm

Hi,
I have bought a second hand Turbo Muin (s/n: 10171) with Misuro.
I use it together with Zwift - everything working fine.
BUT after only 2-4 hours of riding the system writes "Connected" but "No Signal" (no reading of watt).
It is a pain in the butt as there is no warning and it is always during a race.
After I replace the battery, everything is working fine again - but only for 2-4 hours.
What to do?

Best regards
Soren, Copenhagen

User avatar
Elite Admin S
Posts: 1574
Joined: Tue Nov 08, 2016 10:18 am

Re: Using battery in only 2-4 hours

Postby Elite Admin S » Wed Mar 27, 2019 12:40 pm

If there is a so high power consumption, it is necessary to replace the misuro.
Contact us at myetraining@elite-it.com

Regards

spenorden@gmail.com
Posts: 2
Joined: Mon Mar 25, 2019 2:20 pm

Re: Using battery in only 2-4 hours

Postby spenorden@gmail.com » Sun Apr 07, 2019 9:07 am

EXCELLENT SERVICE !
I post my problem. I get a quick answer.
Elite send me a new Misuro B+ free of charge despite the fact that my Turbo Muin and Misuro B+ is very old.
And now everything is working perfectly :-)
Thank you ELITE !

User avatar
Elite Admin S
Posts: 1574
Joined: Tue Nov 08, 2016 10:18 am

Re: Using battery in only 2-4 hours

Postby Elite Admin S » Tue Apr 16, 2019 9:38 am

Thank you for your words!


Return to “Turbo Muin”

Who is online

Users browsing this forum: No registered users and 1 guest