Weird ticking sound when chain leaves rear cassette

Moderators: Elite Admin S, Elite Admin M

d.h.s.addink
Posts: 1
Joined: Sat Jan 30, 2021 10:08 pm

Weird ticking sound when chain leaves rear cassette

Postby d.h.s.addink » Sat Jan 30, 2021 10:24 pm

Hi there,

I bought my Suito-T in December and installed a Shimano 105 R7000 11 Speed (11 / 34 / CS-HG700).
The bike is in real good state (Canyon EDR AL DB 7.0 18 L bk).

I keep having an issue with the chain and the cassette though. It keeps making a noise when the chain comes off the cassette as if it clicks loose. I've perfectly aligned the rear derailleur and tried going back an forth a bit w the indexer but to no avail.

I found exactly the same issue w the same Smart Trainer somewhere online but no solution was given:
-https://bicycles.stackexchange.com/questions/65215/chain-cassette-noise

I thought it was maybe the cassette installation on the freehub but it can't be that either. It was suggested that I should install the cassette w the 1.85 spacer that comes with it but I try this, the cassette will remain which is not a solution.

I'm out of ideas. Please help; I just want a smooth running trainer :(

tristanjwatson
Posts: 2
Joined: Fri Feb 05, 2021 2:21 pm

Re: Weird ticking sound when chain leaves rear cassette

Postby tristanjwatson » Fri Feb 05, 2021 2:28 pm

Hi, I just got the Direto X and put a Shimano 105 10 speed on. There was a horrible grinding sensation and loads of noise from the chain/cassette. I managed to improve the situation by:
1. Taking off the derailleur and giving it a thorough clean.
2. Re-indexing the system
This made it a little better but the problem was still there. So...
3. Put on a new chain to go with the new cassette. This made all the difference and it's now lovely and smooth.

Hope this can be some help...

lukesebmurphy
Posts: 1
Joined: Fri Mar 19, 2021 6:48 am

Re: Weird ticking sound when chain leaves rear cassette

Postby lukesebmurphy » Fri Mar 19, 2021 6:50 am

I had a ticking/clicking issue with the chain. Turned out to be a bend missing link, catching on one of the casette teeth every couple of revolutions. After replacing that, all good.


Return to “Suito”

Who is online

Users browsing this forum: No registered users and 1 guest