Another Suito calibration issue

Moderators: Elite Admin S, Elite Admin M

spcooperb
Posts: 1
Joined: Mon Sep 21, 2020 8:39 pm

Another Suito calibration issue

Postby spcooperb » Sat Sep 26, 2020 2:08 am

I have paired my Suito successfully with myETraining but cannot run a successful calibration - I continually get the calibration failed message. I make sure I have ridden for more than 10 minutes before attempting calibration but cannot get it to work.
I'd appreciate any help!

cleichthammer
Posts: 1
Joined: Mon Oct 05, 2020 4:42 am

Re: Another Suito calibration issue

Postby cleichthammer » Mon Oct 05, 2020 4:50 am

I just set mine up today and have the same problem.

User avatar
Elite Admin S
Posts: 1990
Joined: Tue Nov 08, 2016 10:18 am

Re: Another Suito calibration issue

Postby Elite Admin S » Tue Oct 06, 2020 11:46 am

Hi

Please uninstall the app/software and install it again.
If this won't solve the problem, also try with a different device (just for test) and contact our customer care at myetraining@elite-it.com

Regards

joverowa
Posts: 2
Joined: Sun Oct 11, 2020 11:00 am
Location: Leuven (BE)

Re: Another Suito calibration issue

Postby joverowa » Sun Oct 11, 2020 11:30 am

Same issue here. As Elite Admin S mentionned I already uninstalled the app.
The app just keeps asking tu ride faster. Even if I already ride a 46 - 48 km/hr. And then it says "calibration fails"

I want to calibratie it (bought it second hand) because when I ride a course on my Garmin I feel it's way to hard to ride this course. It's a course next to a canal and I know if I ride there, small chainring in the front 'and the smallest in the back) that is perfect for "relaxing and cooling down".
Now I have to go bigger in the rear and I really have to train (so push hard) to keep it going.
The main goal that I bought this trainer was for riding indoors for recup training. So slow, high cadans and less resistance.

Pairing is also crazy. In the Elite app I can see my speed, cadance,... but If I look in the "bluetooth section of my phone, the Suito is not connected. When I ask my phone to connect, it says 'refused by Suito".

If I want to calibrate it by Zwift I don't see this little wrench button , So I can't try to do this by Zwift.

What is going on here?

I had a Tacx NEO from a friend to test indoor trainers and with that unit I never had any issue.

This is really frustrating. Can someone please help?

PS: Sorry for the errors in my English....

cqbeco
Posts: 3
Joined: Thu Oct 15, 2020 10:23 am

Re: Another Suito calibration issue

Postby cqbeco » Thu Oct 15, 2020 10:29 am

Seems a problem that many of us have, and Elite can't do nothing about it. I've had calibration issues since I have mine (about two or three weeks), because I notice that in a 350/350 watts resistance I could barely move the pedals.I tryed like 50times to calibrate the trainer in Elite's app, without any success. I'm still waiting for an answer from Elite support, but I guess it's a flaw that they cannot solve without sending the trainer back for warranty.

cqbeco
Posts: 3
Joined: Thu Oct 15, 2020 10:23 am

Re: Another Suito calibration issue

Postby cqbeco » Thu Oct 15, 2020 10:38 am

Also this!

joverowa wrote:Same issue here. As Elite Admin S mentionned I already uninstalled the app.
The app just keeps asking tu ride faster. Even if I already ride a 46 - 48 km/hr. And then it says "calibration fails"

Now I have to go bigger in the rear and I really have to train (so push hard) to keep it going.

Pairing is also crazy. In the Elite app I can see my speed, cadance,... but If I look in the "bluetooth section of my phone, the Suito is not connected. When I ask my phone to connect, it says 'refused by Suito".

What is going on here?

...

cqbeco
Posts: 3
Joined: Thu Oct 15, 2020 10:23 am

Re: Another Suito calibration issue

Postby cqbeco » Mon Oct 19, 2020 4:00 pm

Hi.
To help in this issue, I leave the answer provided by Elite on an answer to my request for service on a previous e-mail I sent to the Elite's service team. I haven't try it yet, but I'm not very confident...

"(...) Regarding your request
Please try the following:
Power off the trainer
Turn off and on your smartphone/tablet
Enter on My E-Training
Power on the trainer
Go to Settings and select Change configuration

Please be sure:
From "Settings" of your device
Go to "App" ->MyEtraining
On Authorization check if the localization (position) is active
The GPS function of your device and check all again

Then:
From Training go to Level mode
Clic on Start and pedal for 1-2 minutes and then check all again

At the end check again the calibration

PLease keep me updated
Regards"

mike135
Posts: 1
Joined: Tue Oct 20, 2020 11:30 am

Re: Another Suito calibration issue

Postby mike135 » Tue Oct 20, 2020 11:35 am

Sorry for another 'me too' post. On the first day of using my new Suito I tried to calibrate it and after about 3 goes it actually seemed to work. A short while later (perhaps 10 minutes) I thought I'd do it again to check the consistency of the calibration results. I never succeeded. The app kept telling me to go faster... well, I managed 70kmh before I had to stop, but it still didn't attempt to do the spin down and produce a calibration result. This has happened multiple times since and I have not been successful in calibrating.

I'll try the suggestions here, but if it still doesn't work i think it'll be returned to the vendor as not fit for purpose.

szympol
Posts: 1
Joined: Sun Nov 01, 2020 4:41 pm

Re: Another Suito calibration issue

Postby szympol » Sun Nov 01, 2020 4:46 pm

Same issue here... I am very disappointed by the fact that the calibration process cannot be completed. I have tried every hint, which has been mentioned at this thread and also others, but to no avail.

JBowker
Posts: 3
Joined: Sun Oct 25, 2020 11:46 pm

Re: Another Suito calibration issue

Postby JBowker » Sun Nov 01, 2020 8:45 pm

cqbeco wrote:Seems a problem that many of us have, and Elite can't do nothing about it. I've had calibration issues since I have mine (about two or three weeks), because I notice that in a 350/350 watts resistance I could barely move the pedals.I tryed like 50times to calibrate the trainer in Elite's app, without any success. I'm still waiting for an answer from Elite support, but I guess it's a flaw that they cannot solve without sending the trainer back for warranty.

CQBECO - Wodnering if you've heard anything back yet? I tried to calibrate my new unit once. Was unsuccessful, and don't have the issues noted by other users, so am not planning on trying to calibrate again to avoid issues identified. That being said, I DO want to be able to calibrate my unit, as it IS quite hard to pedal at low speed, in low gears, opposite of what the resistance should do as you go into bigger gears on the cassette.


Return to “Suito”

Who is online

Users browsing this forum: No registered users and 1 guest