Cadence - Suito

Moderators: Elite Admin S, Elite Admin M

graham.hobson
Posts: 2
Joined: Wed Sep 02, 2020 4:56 pm

Cadence - Suito

Postby graham.hobson » Wed Sep 02, 2020 5:05 pm

I had been using an on-bike Wahoo cadence sensor (Ant+) for last couple of years with a wheel-on trainer, with very good stable readings on Sufferfest and Zwift. I have recently purchased the Suito, my first interactive trainer, and the cadence readings on Zwift are very erratic.

I have tried using the cadence from the trainer via Bluetooth.
I have tried selecting the on-bike sensor via Ant+ (the trainer still using Bluetooth for other functionality)
I have tried using the trainer with Ant+
I have tried selecting the on-bike sensor via Ant+ (the trainer using Ant+ for other functionality)

In all these scenarios the cadence readings jump all over the place. One minute 95, then drops to 40 for 10 secs then to 80 etc. Constantly going up and down.

What could be causing this, it's very disappointing.

User avatar
Elite Admin S
Posts: 1984
Joined: Tue Nov 08, 2016 10:18 am

Re: Cadence - Suito

Postby Elite Admin S » Thu Sep 03, 2020 9:33 am

Hi

It's necessary to check the data.
Please contact the customer care at support@elite-it.com adding the export of the course.
Also check if you have the same behavior using my e-training

Regards

riccardo.rebichini
Posts: 2
Joined: Wed Dec 02, 2020 8:45 pm

Re: Cadence - Suito

Postby riccardo.rebichini » Wed Dec 02, 2020 8:54 pm

Any answer from the support? I have similar problems


Return to “Suito”

Who is online

Users browsing this forum: No registered users and 2 guests