Suito resistance way too high

Moderators: Elite Admin S, Elite Admin M

hugsps
Posts: 1
Joined: Thu Feb 11, 2021 8:34 pm

Re: Suito resistance way too high

Postby hugsps » Thu Feb 11, 2021 8:54 pm

After circa six months use Suito has exact same problem. Now have a strange noise when electric power is switched on for a few seconds and then can’t turn pedals.

Update 26 Feb 2021
Issue resolved with replacement electrical board. Circa 10 minutes to replace.
Now to tackle the next problem the creaking noises
Last edited by hugsps on Sun Feb 28, 2021 10:14 am, edited 1 time in total.

glennVS
Posts: 2
Joined: Mon Feb 15, 2021 9:06 pm

Re: Suito resistance way too high

Postby glennVS » Mon Feb 15, 2021 9:16 pm

Same issue

After using the old Suito for about 6 months, I just received my new Suito-T two days ago. I took it for a 10 minute warmup spin in the My E-training app and did a calibration through the app directly after.

When I went for a spin on Zwift an hour or 2 later, the resistance was significantly harder than I used to get with the old Suito. Thought it might be the Jungle ride I did. Unfortunately the next day it felt just as bad again on a flat course. I'll be reaching out to the support tomorrow and we'll see. Keeping you guys posted.

red.hell
Posts: 8
Joined: Wed Dec 23, 2020 10:10 pm

Re: Suito resistance way too high

Postby red.hell » Tue Feb 16, 2021 9:51 pm

glennVS wrote:Same issue

After using the old Suito for about 6 months, I just received my new Suito-T two days ago. I took it for a 10 minute warmup spin in the My E-training app and did a calibration through the app directly after.

When I went for a spin on Zwift an hour or 2 later, the resistance was significantly harder than I used to get with the old Suito. Thought it might be the Jungle ride I did. Unfortunately the next day it felt just as bad again on a flat course. I'll be reaching out to the support tomorrow and we'll see. Keeping you guys posted.


if you took jungle ride with a racing bike in game it will be hard, on gravel you need double power than a mtb to reach same speed

try a full tarmac ride to have a check, and don't set trainer difficulty too high

glennVS
Posts: 2
Joined: Mon Feb 15, 2021 9:06 pm

Re: Suito resistance way too high

Postby glennVS » Fri Feb 19, 2021 5:23 pm

red.hell wrote:
glennVS wrote:Same issue

After using the old Suito for about 6 months, I just received my new Suito-T two days ago. I took it for a 10 minute warmup spin in the My E-training app and did a calibration through the app directly after.

When I went for a spin on Zwift an hour or 2 later, the resistance was significantly harder than I used to get with the old Suito. Thought it might be the Jungle ride I did. Unfortunately the next day it felt just as bad again on a flat course. I'll be reaching out to the support tomorrow and we'll see. Keeping you guys posted.


if you took jungle ride with a racing bike in game it will be hard, on gravel you need double power than a mtb to reach same speed

try a full tarmac ride to have a check, and don't set trainer difficulty too high


I did the Jungle ride on the MTB. The trainer difficulty is around 50%. And a full tarmac ride on Tempus Fugit didn't make a lot of difference. So it might be a difference between the trainers I have to get used to. However, I've just picked up my new bike ( :D ) but the frontderailleur seems the have some troubles ( :( not able to change from the small to the big ring, as it seems the chain is not able to reach the ring properly) when it is attached to the trainer. I'll need to get that sorted before the trainer fix continues.

hinnisiemsen
Posts: 1
Joined: Sat Mar 06, 2021 11:56 am

Re: Suito resistance way too high

Postby hinnisiemsen » Sat Mar 06, 2021 11:59 am

nessim.sakka wrote:Hi guys. If any of you have a Wahoo computer znd paired it to the Suito THIS IS THE CAUSE! Found a post about this. I had connected my wahoo as a first step after unboxing.

I removed the trainer from my wahoo, went to Elite My Etraining app, selected a workout, started pedaling and after a couple of seconds I stopped. (You don’t need to finish the workout).

THIS FIXED MY RESISTANCE ISSUE. Go figure.


Hooly moly, this fixed my issue aswell!!!!
Use the free code from Elite for their training app, delete the device in your Wahoo Elemnt before and do a power training for a minute, all fixed!!

@Elite Try putting this in Troubleshooting or FAQ for people to see, its a 5 minute fix and saves you alot of manpower!!
And maybe bring out a software update fixing this wahoo issue, I‘m using the Suito-T, Firmware 191 and hardware devision 5, and a Wahoo Elemnt Bolt on newest firmware.

Thanks again nessim saka, you are my hero <3


Return to “Suito”

Who is online

Users browsing this forum: No registered users and 3 guests