Suito resistance way too high

Moderators: Elite Admin M, Elite Admin S

dustedrob
Posts: 2
Joined: Wed May 27, 2020 6:49 pm

Suito resistance way too high

Postby dustedrob » Wed May 27, 2020 7:31 pm

I just got a brand new Elite Suito and wanted to take it for a test ride but I found the resistance to be extremely tight for anything. I'm pushing >400 watts on the small chainring and largest cog to even get it to move. I tried doing the calibration on the Android and Windows app and It's impossible to get it to speed. The same for Zwift.

I've used other smart trainers in the past and I feel this is very abnormal. It shouldn't be as tight as it is. Is there a way to manually reduce the resistance on the trainer? or maybe the unit is defective?

I made sure that it is using the latest firmware with the upgrado app.

msgcycle
Posts: 2
Joined: Mon Jun 08, 2020 7:20 pm

Re: Suito resistance way too high

Postby msgcycle » Mon Jun 08, 2020 7:22 pm

I am having the same issue. Opened a ticket for it. The resistance is hard and does not respond to changes in terrain in Zwift, which it did until a month ago. Can't use it now as I am gassed after about 10 minutes pedaling. And I have yet to find a way to calibrate it.

adamklein
Posts: 1
Joined: Tue Sep 15, 2020 5:55 am

Re: Suito resistance way too high

Postby adamklein » Tue Sep 15, 2020 5:36 pm

I'm also having this issue. Did either of you get it fixed?

ynikolov
Posts: 1
Joined: Sat Sep 19, 2020 1:57 pm

Re: Suito resistance way too high

Postby ynikolov » Mon Sep 21, 2020 9:00 am

Hi there,

I have exactly the same problem. I have just got the Suito two days ago and was so excited to start pedaling with it. I have set up myEtraining and Kinomap. After about 15 minutes of ride the resistance got too high that i was pushing a lot of power trying to rotate that pedals. The resistance was way to high and stopped responding to any change in elevation or power. The calibaration is not possible. I tried several times but it was failing each time. I tried resetting everything, reinstalling the tools....everything.

Is there a way somehow to the set the Suito to its factory settings.

I have opened a ticket already but decided to share my experience here as well. The device is not usable. Waiting for any feedback with a hope to fix it

As an additional info i have to say that I can hear sounds out of the trainer when changes in the evaluation starts however there is no change in the resistance. Seems like the brake is somehow blocked...the trainer/software tries to change the break position but it can not due to a mechanical issue.

Could it be that some reference values for the brake position are messed up? Therefore i was asking for kind of reset to factory option


Regards


Return to “Suito”

Who is online

Users browsing this forum: No registered users and 1 guest