Elite Nero Connection Error

Moderators: Elite Admin S, Elite Admin M

kimbogus
Posts: 5
Joined: Tue Jan 26, 2021 3:42 pm

Elite Nero Connection Error

Postby kimbogus » Tue Jan 26, 2021 3:49 pm

Hey Guys,

sinc a day now (Jan 25th) I have connection issues with my Elite Nero. Both with Ant+ and Bluetooth I can connect to my Garmin Device and to Zwift but as soon as I start pedaling (3 to 4 strokes) the Power is no longer shown and the resistance is no longer adjustet automatically. This appears no matter the connection via Garmin Device, Zwift companion or direct internal Bluetooth (PC). The Nero Elite is still shown as connected, but power is not transmitted as well as the automatic resistance. Only cadence is shown.
It happened as well with the old firmware as with the newest.

As i have read a lot Elite Service seems more than bad so I guess I won't get help from them. At least i will give it a try and opened a ticket.

Anyone having the same issue being able to help me?

Thx guys
Kim

ThomasHu
Posts: 5
Joined: Wed Jan 29, 2020 4:00 pm

Re: Elite Nero Connection Error

Postby ThomasHu » Wed Feb 03, 2021 11:54 am

Don't expect any help here regarding Nero. Elite has probably abandoned the product and leaves its customers alone with the faults. I am more than disappointed with Elite. After all, the Nero costs 700€ and should get support at this price. The compatibility with Zwift is also a joke.

Best regards
Thomas

kimbogus
Posts: 5
Joined: Tue Jan 26, 2021 3:42 pm

Re: Elite Nero Connection Error

Postby kimbogus » Tue Feb 09, 2021 11:04 pm

Hi ThomasHu,

Elite contacted me and helped with my issue.
I don't know why, but in the my E-Trainging the power meter link was activated, why the Elite Nero kept trying to connect to my p2m Powermeter which a have not activated yet. As the p2m does send 0 watts there, the Nero did not sent any data to Zwift or Garmin. Deactivating the power link option in the e-training app solved the problem.

But since the update another problem occurs. Now the power/resistance in general is pretty messed up and I am having struggling reaching even 140 watts in Zwift.
Sad but true, the Nero is not working properly

ThomasHu
Posts: 5
Joined: Wed Jan 29, 2020 4:00 pm

Re: Elite Nero Connection Error

Postby ThomasHu » Mon Feb 15, 2021 9:24 pm

kimbogus wrote:Hi ThomasHu,

Elite contacted me and helped with my issue.
I don't know why, but in the my E-Trainging the power meter link was activated, why the Elite Nero kept trying to connect to my p2m Powermeter which a have not activated yet. As the p2m does send 0 watts there, the Nero did not sent any data to Zwift or Garmin. Deactivating the power link option in the e-training app solved the problem.

But since the update another problem occurs. Now the power/resistance in general is pretty messed up and I am having struggling reaching even 140 watts in Zwift.
Sad but true, the Nero is not working properly


Hi Kim,
I'm surprised... Nevertheless, it looks like that Elite still does not fix your issues. Let the forum know how it goes with your support case.

Good luck and happy zwifting...
Thomas


Return to “Nero”

Who is online

Users browsing this forum: No registered users and 1 guest