Nero Smart Rollers doesn't work properly

Moderators: Elite Admin S, Elite Admin M

Posts: 1
Joined: Wed May 08, 2019 3:04 am
Location: Australia

Nero Smart Rollers doesn't work properly

Postby cannonrider » Sun Jun 02, 2019 6:37 pm

I bought Nero smart roller trainer a week ago and using it for Zwift and TrainerRoad but Nero's resistance doesn't changing according to the target power (Trainer Road) or gradient (Zwift).

So, i did calibration few times and "Power Meter Link" option but still same.
The Nero's power reading accuracy isn't too bad compare to my bike power meter (Pioneer dual power meter).

Please let me know how to synchronize the Nero roller's resistance with training application such as Zwift and Traing Road.


Posts: 13
Joined: Wed May 15, 2019 10:56 pm

Re: Nero Smart Rollers doesn't work properly

Postby dwtrux » Wed Jun 19, 2019 9:41 pm

I have tried the Power Meter Link up as well and got 0 on any app I was using. However, I was able to connect my power meter pedals directly to My E Training app as another sensor instead. Not sure how to use the Power Meter Link section of the parameters in the My E app or why the watts go to 0 when you do have that set up. May be because I am using a Bluetooth connection to iPad and not an Ant+ FE-C to a computer etc.

Posts: 1
Joined: Wed Jul 17, 2019 9:14 pm

Re: Nero Smart Rollers doesn't work properly

Postby Superonik » Wed Jul 17, 2019 9:19 pm

I have the same problem , no resistance change in TrainerRoad.
Do you have a solution ?
Posts: 1
Joined: Wed Jul 24, 2019 4:50 pm

Re: Nero Smart Rollers doesn't work properly

Postby » Wed Jul 24, 2019 4:53 pm

I’ve been using a Kickr on the Trainerroad platform for a couple years, and I just picked up a new Nero. The connection of the Kickr was amazingly easy, but I tried for a couple hours last night to get the Nero working without success. I’m using a current Samsung S9 via Bluetooth and it recognizes the Nero instantly. When I try to do a spindown it gives me "Spindown Calibration Failed Calibration attempt timed out" error every time. I tried it about 15 times, rebooted the phone, Nero, etc. When I tested a simple workout in ERG mode, the phone wasn’t controlling the Nero since the power displayed was well above the target power.

In the set up app that Elite has, the spindown doesn’t seem to work either. It prompts to “start pedaling” but even after 15 mins of pedaling it still says “start pedaling.” In the setup, it asks for ANT+ or Bluetooth (always defaults to ANT+ it looks like), and I’ve tried both without success.

Any ideas? I appreciate your help!

Return to “Nero”

Who is online

Users browsing this forum: No registered users and 2 guests