Has my Elite Qubo Digital Smart B+ Turbo Trainer died?

Moderators: Elite Admin S, Elite Admin M

andycole
Posts: 1
Joined: Sun Dec 31, 2017 6:57 pm

Has my Elite Qubo Digital Smart B+ Turbo Trainer died?

Postby andycole » Sun Dec 31, 2017 7:09 pm

Been using a Elite Qubo Digital Smart B+ FE-C Turbo Trainer since buying new in June 2017, in the past few days I've noticed a few issues and today's rendering it a dumb trainer.

1. Very noisy and lots of friction applied to the rear wheel
2. Elastomer roller marked from trainer tyre
3. ANT+ connection dropped out and wont re-pair to Zwift, HR and cadence are still available so ANT+ dongle is good
4. Zwift sees the unit bluetooth connection although set in Elite App for ANT+
5. No tension applied to rear wheel so basically a dumb trainer in 0% gradient

Obviously not the easiest to return by post as a warranty claim so looking for any ideas or fault invest I can do
Cheers
AC

User avatar
Elite Admin S
Posts: 1351
Joined: Tue Nov 08, 2016 10:18 am

Re: Has my Elite Qubo Digital Smart B+ Turbo Trainer died?

Postby Elite Admin S » Thu Jan 25, 2018 12:04 pm

Good morning

I see that you're already in contact with our customer care about this issue.

Regards

roblyons1982
Posts: 1
Joined: Wed Mar 14, 2018 9:18 pm

Re: Has my Elite Qubo Digital Smart B+ Turbo Trainer died?

Postby roblyons1982 » Wed Mar 14, 2018 9:21 pm

Hi AndyCole,

Did you get anywhere with your problem?
The problem I've been having with mine is it's become easier and easier to spin up to 500w ish without too much effort, and now tonight seems there is no resistance, hit over 900w and 10.5w/kg easily. Seems like the trainer may have died also

User avatar
Elite Admin S
Posts: 1351
Joined: Tue Nov 08, 2016 10:18 am

Re: Has my Elite Qubo Digital Smart B+ Turbo Trainer died?

Postby Elite Admin S » Tue Mar 27, 2018 12:55 pm

@roblyons,

AndyCole had a mechanical issue.
In your case, it seems more an electronic issue, please contact our customer care at real@elite-it.com

Regards

stevebourgeault
Posts: 1
Joined: Wed Oct 31, 2018 5:28 pm

Re: Has my Elite Qubo Digital Smart B+ Turbo Trainer died?

Postby stevebourgeault » Wed Oct 31, 2018 5:32 pm

i seem to have a problem where the last few trainings i did the resistance doesnt seem to adjust to the incline (in zwift)btw it is correctly paires in zwift. I tried to connect with the elite app and it took about 4 power on/ power off for the unit to respond to increase in resistance (1-16) and being able to hear the device moving the margnet. i will try tonight with the elite app to see if the resistance effectively changes while pedaling and hearing that the magnet moves.


Return to “Qubo Digital / Novo Smart”

Who is online

Users browsing this forum: No registered users and 2 guests