Qubo Digital Interactive no power on flats or downhill

Moderators: Elite Admin S, Elite Admin M

velocedge
Posts: 5
Joined: Mon Mar 12, 2018 8:43 pm

Qubo Digital Interactive no power on flats or downhill

Postby velocedge » Sun Dec 09, 2018 9:40 pm

We have 2 Qubo Digitial Interactive trainers we purchased from Performance Bicycle 11/28/2017 and one of them quit working with Zwift on flats or down hill. Performance is going out of business and won't help me at all. All I can produce on flats is about .9 w/kg. On the uphill, it's still about normal for me, about 3.5 w/kg. I have MyTraining app and have reset the trainer but it hasn't changed. Is there anything else I can try?

velocedge
Posts: 5
Joined: Mon Mar 12, 2018 8:43 pm

Re: Qubo Digital Interactive no power on flats or downhill

Postby velocedge » Tue Dec 11, 2018 7:03 pm

Now there is considerable resistance all the time. I can only use my lowest two gears in my small chain ring. When you plug it in, unlike the other one that sounds like it's shifting something inside. This one just makes a very quiet but constant da, da, da, da, da... etc. noise.

weldeinwalm
Posts: 1
Joined: Thu Aug 08, 2019 11:44 am

Re: Qubo Digital Interactive no power on flats or downhill

Postby weldeinwalm » Thu Aug 08, 2019 11:46 am

velocedge wrote:Now there is considerable resistance all the time. I can only use my lowest two gears in my small chain ring. When you plug it in, unlike the other one that sounds like it's shifting something inside. This one just makes a very quiet but constant da, da, da, da, da... etc. noise. Now all Walmart employees can make use of Walmartone.com portal to get all the benefits.

I don't think thats it is worst business model


Return to “Qubo Digital / Novo Smart”

Who is online

Users browsing this forum: No registered users and 2 guests