Faulty power adapter?

Moderators: Elite Admin S, Elite Admin M

josephmyoung68
Posts: 1
Joined: Fri Jul 12, 2019 3:20 pm

Faulty power adapter?

Postby josephmyoung68 » Fri Jul 12, 2019 3:27 pm

I have been using my Elite Direto for 18 months and love it. I have had no problems with the power (AC adapter), even though I generally leave it plugged in when not using it. However, last Saturday I set it up for a pre-race quick ride, and discovered that I had no power connection through the adapter. No LED lights, no sounds, no connection with Zwift.

Is it possible that the AC power adapter has gone faulty and needs replacing? Perhaps perspiration or dust has corroded the connection somehow?

Please advise. Thanks so much-- I want to get back to training indoors!

Joseph

placebo_09
Posts: 2
Joined: Sat Dec 21, 2019 4:15 pm

Re: Faulty power adapter?

Postby placebo_09 » Sat Dec 21, 2019 4:18 pm

I am having a similar problem. Two days ago I rode with my Direto fine. Today there is no power and a grey liquid is coming from the AC box where it attached to the power outlet. There are not water sources near where I plug in.

nicholasrbailey
Posts: 1
Joined: Sun Feb 02, 2020 7:02 pm

Re: Faulty power adapter?

Postby nicholasrbailey » Sun Feb 02, 2020 7:06 pm

Any update on this? Did you replace the power adaptor? I’m having the same issue. I’ve owned my Direto for a year and I unplug it and pack it away after every use. I tried to use it last night and the lights won’t come on and no sound.

placebo_09
Posts: 2
Joined: Sat Dec 21, 2019 4:15 pm

Re: Faulty power adapter?

Postby placebo_09 » Sat Feb 08, 2020 5:58 pm

I found a replacement by googling the information printed on the adapter. I ordered a compatible adapter at https://www.digikey.ca/product-detail/e ... ND/5418518 and the North America plug https://www.digikey.ca/product-detail/e ... ND/2384507.

It works fine so far. No problems since January. I am in Canada. I suspect the products are available elsewhere such as the US for sure.

The fact we the customers have to share our solutions to Elite issues indicates a very poor level of support from Elite.

Regards

sublettelifty
Posts: 1
Joined: Mon Jun 08, 2020 8:34 pm

Re: Faulty power adapter?

Postby sublettelifty » Mon Jun 08, 2020 8:36 pm

Yes i just bought a Drivo II a month or so ago. yesterday i rode NY on zwift for 2 hours, today i cant get anything, no lights, no sound. im bummed


Return to “Direto & Direto X”

Who is online

Users browsing this forum: No registered users and 5 guests