Direto Erg mode - new problem - power rises every 20-40 seconds

Moderators: Elite Admin S, Elite Admin M

PhilSJones
Posts: 9
Joined: Fri Oct 26, 2018 11:04 am

Direto Erg mode - new problem - power rises every 20-40 seconds

Postby PhilSJones » Fri Nov 09, 2018 6:31 pm

I am doing workouts in TrainerRoad with Direto. They have been going well using Erg mode (See my other post about problems with Zwift and MyEtraining software).

However Today I started a TrainerRoad workout and immediately hit a problem. I was supposed to be at around 100W for a few minutes for a warm up, but every 20-40 seconds the resistance would suddenly increase and I would have to push to over 300W to get over it, for a few seconds. Then it would drop back.

It was NOT the TR software changing power, but the trainer. I am using a PC and ANT

After several restarts I gave up and decided to see what was happening using the MyETraining software in level mode. I set it to level 5 and started pedaling at around 200W. it was clear. Every 20 or 40 seconds, the power/resistance would suddenly change for a few seconds to around 300 plus watts so I would have to push through that and then come down again to 200W. This happened for over 10 minutes consistently. The patter seemed to be every 40 seconds, then 20, then 40 and so on.

I stopped, after 12 minutes, recalibrated the trainer, and tried again. Same problem.

It is basically unusable. I am massively disappointed with the trainer.

I have tried to attach the fit file of the session but your software/forum says it is an invalid file type. And images are too large. Frustrating.

PhilSJones
Posts: 9
Joined: Fri Oct 26, 2018 11:04 am

Re: Direto Erg mode - new problem - power rises every 20-40 seconds

Postby PhilSJones » Mon Nov 12, 2018 10:19 am

Ok I solved this one - partially. [update 12/nov/2018 See this and next post for full solution]

My bike has a wahoo elemnt and my garmin 920 on it for my garmin vector pedals.

The Elemnt was also paired with the Direto. However it goes into a mode that controls a kickr and it was offering the same for the Direto. If I switched off the elemnt, unpaired the turbo or put the wahoo into passive mode, then this 20second increase in resistance went away.

However, it raises three questions

1) Why was this not happening before. I did at least 10 sessions before this occurred. In each case the elemnt was paired and connected with the Direto and in a level mode, as it was when the problem started.
2) What is actually going on that causes the direto to increase resistance every 20 or 40 seconds, irrespective of the wahoo being touched or the direto being in erg or sim mode.

3) Finally Given the wahoo elemnt CAN control the direto in its various modes (Level, resistance, ride this route), etc. I still suspect this is a bug of some kind.

Please have a look at this Elite.
Last edited by PhilSJones on Mon Nov 12, 2018 5:05 pm, edited 2 times in total.

PhilSJones
Posts: 9
Joined: Fri Oct 26, 2018 11:04 am

Re: Direto Erg mode - new problem - power rises every 20-40 seconds

Postby PhilSJones » Mon Nov 12, 2018 5:04 pm

OK further update. Wahoo (in a nice quick response) tell me that they released an update on 7th November that fixed a problem with their Elemnt NOT communicating with and controlling third party trainers!

The Wahoo will control the resistance, level, etc. of the Direto now (But also causes this problem of pulses of resistance). So as the problem started immediately after that upgrade was released, I have contacted Wahoo and suggested they recheck this "feature" for the Direto and elite range.

What is nice is that they came back pretty quickly and were honest about the change.

Refreshing :)


Return to “Direto”

Who is online

Users browsing this forum: No registered users and 1 guest