Direto Erg mode has inconsistent behaviours Zwift, my E-Trainer & TrainerRoad

Moderators: Elite Admin S, Elite Admin M

PhilSJones
Posts: 9
Joined: Fri Oct 26, 2018 11:04 am

Direto Erg mode has inconsistent behaviours Zwift, my E-Trainer & TrainerRoad

Postby PhilSJones » Wed Oct 31, 2018 12:07 pm

Please help because I am finding my new Direto in Erg mode has inconsistent behaviours Zwift, my E-Trainer & TrainerRoad

In summary, in erg mode, I get a delay of between 3-4 seconds as the intervals change power from say 130W to 350 BEFORE the power transition starts. The actual transition takes another 7-10 seconds. This happens in both Zwift workouts and with sessions created and run inside the Elite MyETrainer software. Curiously it does NOT happen with TrainerRoad. TrainerRoad changes immediately, transitioning immediately an interval starts and transitions in 3-4 seconds to the new powerlevel.

This is a curious and inconsistent behaviour. I explain my detailed tests below. All tests were conducted using a PC and Ant+ dongle, and a Garmin Cadence sensor on my pedals.

First Zwift in workout and Erg mode. When I got the turbo trainer I started with Zwift and the 4week FTP booster programme. These Zwift sessions typically have intervals that go from 130W at 80, the 350W for 30sec at 95.
I struggled in Erg mode when an interval moved from say 130W to 350 for 30 seconds or so. I was struggling to match either power or cadence. Not because I could not produce it, but because I would overshoot and have to ease off and let things settle down. It was very frustrating. Initially I could not work out what the problem was. Once started, longer intervals, say 5 minutes or so, were fine (usual oscillation, but that is not an issue). The issue occurred when starting the interval or finishing, where it was taking 15 seconds or so to get back down to a stable power level and cadence. I was frustrated by this.

I tried changing the power smoothing setting as suggested in other forum entries. It made no difference.
IN MyETrainer: So, I tried doing the same type of session in MyETrainer to eliminate Zwift. In MyEtrainer I created a short session of 6 x(30 seconds at 350W, followed by 30sec at 130W) with a short warm up and warm down.

It was immediately obvious that there was a problem. The interval timer would come to the end of the previous interval, I would start to increase power to 350W as the new interval started. However, the new power had not kicked in, on the turbo, even though it was showing on the screen in MyETRainer. In fact, it was taking 3-4 seconds BEFORE the power would change, then another 10 seconds to transition to the new power level. This was happening when the power rose and when the power dropped. So, a 350W set would end but it would hold 350W for 3-4 seconds before transitioning down to 130W. Surely this was not how it should work, surely?

The only way I could do the session was to pause 3-4 seconds into the interval until I felt the power/resistance change, and then put the power on. Likewise, when the interval timer finished I had to continue into the next interval at the high power for 3-4 seconds until I felt the resistance drop away, and then ease off the pressure and cadence. It was the only way to make the session work.
It made me realise what was happening with Zwift. In the e-trainer, if I started increasing power and cadence immediately the interval started I would still be at 130W instead of 350W and so would quickly spin up from say 90 to 115rpm, at which point the transition to 350W would start (3-4 seconds in). I would end up trying to manage the power at 350W but at 110rpm.
At this point I suspected the turbo trainer itself was faulty. It was clearly not going to help me do the sort of interval sessions I wanted for my training.

In Trainer Road: As an experiment I thought I would try Trainer road. I constructed exactly the same session in the TrainerRoad Workout Creator: 6 lots of (30seconds at 350W followed by 30seconds at 130W).

Running this inside TrainerRoad, it was immediately obvious that the resistance would change IMMEDIATELY the new interval started. It also lowered IMMEDIATELY the interval finished. The transition from 130W to 350W was taking 3-4 seconds. Ther was no delay in starting.
This meant that I could power straight up to the new level and be there within 5-7 seconds. I could also wind down immediately the timer finished its interval and started the new one.

At last this was how it should work. I was able to do exactly what Shane, Lama says in his Erg mode video about pushing through in erg mode to change power levels.

This is also more consistent with what I read from DCRainmaker in his review. He says the Direto “transitions power in 3-4 seconds.” Whereas what I was finding, with both Zwift and the MtETrainer software is that there is a delay of 3-4 seconds and then a transition that takes another 7-10 seconds.

Zwift in sim mode. That works fine. As does TrainerRoad and MyETrainer in Resistance mode. It is Zwift and MyETrainer in Erg mode that has problems.

Conclusion

There is clearly something going wrong, in erg mode, with the interface between the Direto and both Swift and its native MyETrainer software.
In contrast, using TrainerRoad is perfect. It behaves just as I hoped and expected and delivers an experience that means transitions between intervals is easy to manage.

Something is clearly wrong somewhere with the interfaces with these other applications.

Please advise.

francescostudiogiovannini
Posts: 6
Joined: Fri Oct 26, 2018 11:42 pm

Re: Direto Erg mode has inconsistent behaviours Zwift, my E-Trainer & TrainerRoad

Postby francescostudiogiovannini » Tue Feb 26, 2019 2:37 pm

Thanks PhilSJones,
so i have to consider to left Zwift and upgrade to TrainerRoad. I have your same problems with Direto on Zwift.
It's impossible make a decent workout concerning shorts high power sprints.
Btw i hate to see that Direto II is on sale as Zwift's certified trainer https://zwift.com/shop/product/elite-di ... rt-trainer but isn't really 100% supported, starting from the fact that you can not even calibrate in the application of Zwift but only in the Elite MyEtraining application.
That's all.

cedricg_38
Posts: 7
Joined: Thu Aug 30, 2018 12:57 pm

Re: Direto Erg mode has inconsistent behaviours Zwift, my E-Trainer & TrainerRoad

Postby cedricg_38 » Thu Feb 28, 2019 9:08 am

Be sure to power on direto before launch zwift. If you run zwift before direto, direto will not have any feedback control ...


Return to “Direto”

Who is online

Users browsing this forum: No registered users and 4 guests