Direto Erg mode has inconsistent behaviours Zwift, my E-Trainer & TrainerRoad

Moderators: Elite Admin S, Elite Admin M

Posts: 9
Joined: Fri Oct 26, 2018 11:04 am

Direto Erg mode has inconsistent behaviours Zwift, my E-Trainer & TrainerRoad

Postby PhilSJones » Sun Oct 28, 2018 8:00 pm

In summary, in erg mode, I get a delay of between 3-4 seconds as the intervals change power from say 130W to 350 BEFORE the power transition starts. The actual transition takes another 7-10 seconds. This happens in both Zwift workouts and with sessions created and run inside the Elite MyETrainer software. Curiously it does NOT happen with TrainerRoad. TrainerRoad changes immediately, transitioning immediately an interval starts and transitions in 3-4 seconds to the new powerlevel.

This is a curious and inconsistent behaviour. I explain my detailed tests below. All tests were conducted using a PC and Ant+ dongle, and a Garmin ANT+ Cadence sensor on my pedals.

First Zwift in workout and Erg mode. When I got the turbo trainer I started with Zwift and the 4week FTP booster programme. These Zwift sessions typically have intervals that go from 130W at 80, the 350W for 30sec at 95.

I struggled in Erg mode when an interval moved from say 130W to 350 for 30 seconds or so. I was struggling to match either power or cadence. Not because I could not produce it, but because I would overshoot and have to ease off and let things settle down. It was very frustrating. Initially I could not work out what the problem was. Once started, longer intervals, say 5 minutes or so, were fine (usual oscillation, but that is not an issue). The issue occurred when starting the interval or finishing, where it was taking 15 seconds or so to get back down to a stable power level and cadence. I was frustrated by this.

I tried changing the power smoothing setting as suggested in other forum entries. It made no difference.

IN MyETrainer: So, I tried doing the same type of session in MyETrainer to eliminate Zwift. In MyEtrainer I created a short session of 6 x(30 seconds at 350W, followed by 30sec at 130W) with a short warm up and warm down.

It was immediately obvious that there was a problem. The interval timer would come to the end of the previous interval, I would start to increase power to 350W as the new interval started. However, the new power had not kicked in, on the turbo, even though it was showing on the screen in MyETRainer. In fact, it was taking 3-4 seconds BEFORE the power would change, then another 10 seconds to transition to the new power level. This was happening when the power rose and when the power dropped. So, a 350W set would end but it would hold 350W for 3-4 seconds before transitioning down to 130W. Surely this was not how it should work, surely?

The only way I could do the session was to pause (Continue at current power level) for 3-4 seconds into the interval until I felt the power/resistance change, and then put the power on. Likewise, when the interval timer finished I had to continue into the next interval at the high power for 3-4 seconds until I felt the resistance drop away, and then ease off the pressure and cadence. It was the only way to make the session work.

It made me realise what was happening with Zwift. In the MyETrainer, if I started increasing power and cadence immediately the interval started I would still be at 130W instead of 350W and so would quickly spin up from say 90 to 115rpm or higher, at which point the transition to 350W would start (3-4 seconds in). I would end up trying to manage the power at 350W but at 110rpm. and be desperately trying to lower my cadence without dropping the power level.

At this point I suspected the turbo trainer itself was faulty. It was clearly not going to help me do the sort of interval sessions I wanted for my training. However I continued to experiment.

In TrainerRoad: As an experiment I thought I would try Trainer road. I constructed exactly the same session in the TrainerRoad Workout Creator: 6 lots of (30seconds at 350W followed by 30seconds at 130W).

Running this inside TrainerRoad, it was immediately obvious that the resistance would change IMMEDIATELY the new interval started. It also lowered IMMEDIATELY the interval finished. The transition from 130W to 350W was taking 3-4 seconds. There was no delay in starting.
This meant that I could power straight up to the new level and be there within 5-7 seconds. I could also wind down immediately the timer finished its interval and started the new one.

At last this was how it should work. I was able to do exactly what Shane, Lama says in his Erg mode video about pushing through in erg mode to change power levels. This is also more consistent with what I read from DCRainmaker in his review. He says the Direto “transitions power in 3-4 seconds.” Whereas what I was finding, with both Zwift and the MyETrainer software is that there is a delay of 3-4 seconds and then a transition that takes another 7-10 seconds.

Zwift in sim mode. That works fine. As does TrainerRoad and MyETrainer in Resistance mode. It is Zwift and MyETrainer in Erg mode that has problems.

There is clearly something going wrong, in erg mode, with the interface between the Direto and both Swift and its native MyETrainer software.
In contrast, using TrainerRoad is perfect. It behaves just as I hoped and expected and delivers an experience that means transitions between intervals is easy to manage.

Something is clearly wrong somewhere with the interfaces with these other applications.

Please advise. I hope these experiments and the experiences help someone sort this out.

User avatar
Elite Admin S
Posts: 1846
Joined: Tue Nov 08, 2016 10:18 am

Re: Direto Erg mode has inconsistent behaviours Zwift, my E-Trainer & TrainerRoad

Postby Elite Admin S » Thu Nov 08, 2018 2:38 pm


Direto uses an internal stepping motor that moves a magnetic arm to adjust the trainer resistance.
This means that it takes some time to reach the requested position. The bigger the power gap, the longer the time it takes to reach the position.
So, this is the first cause of the delay.

But this is not all.
You have also some delay due to the software.
In fact, the software must acknowledge that there is a segment change, calculate the new resistance (basing on the speed) and send the command to the trainer. This also requires some time (little, but there is it) and may be different from a software or another.

Finally, there may be also a delay due to communication. If there are interferences, a data packet may be lost and the command of changing resistance may be sent multiple times. This add another little delay.

I don't know why you don't have the same behavior with TrainerRoad, as the most of the delays are not "evitable".

Posts: 9
Joined: Fri Oct 26, 2018 11:04 am

Re: Direto Erg mode has inconsistent behaviours Zwift, my E-Trainer & TrainerRoad

Postby PhilSJones » Thu Nov 08, 2018 4:59 pm

Thank you for posting this at last. As I say it is definitely taking 3-4 seconds BEFORE the turbo trainer starts to react, But not in TrainerRoad, where the transition to a new power level starts immediately.

I can understand that it takes some time to adjust from one position to another (one power to another). However It is not STARTING to adjust until 3-4 seconds and that adjustment is talking another 6-10 seconds. (You would not want an immediate and sudden transition anyway - that would be like hitting a brick wall).

Can i suggest you actually try this. PLEASE. Make a short custom exercise in Zwift, MyETrainer and Trainerroad. All you need is
1 minute at 130W, then 3 lots of 30 second at 300W and back to 130W. (Then a short warm down). Try it.

You will immediately feel and even hear the delay. And you will understand that it is not occurring with TrainerRoad.

Then perhaps try it with a different type of smart trainer or different brand. (I am sure you have a few around).

I demonstrated it to your UK distributor on Tuesday evening. That was using his bike, his PC, his ANT and his Direto. He was as surprised as I was to witness it.

Data packets do not take 4 seconds to travel one metre, even repeated packets sent for redundancy. The cadence signal is reaching the PC.

I genuinely think you have a problem here. Please please set up this experiment and try it for yourselves. You will definitely notice it.

It makes using Zwift workouts or you "MyETraining software really difficult to use in erg mode, especially for reasonable sized jumps. Bearing mind I am not some superhero. I am only going from 130 to 350 or so. There is nothing massive in that compared with track sprinter etc.

Please please test this for yourselves and experience this for yourselves...

Posts: 2
Joined: Wed Jan 09, 2019 9:07 pm

Re: Direto Erg mode has inconsistent behaviours Zwift, my E-Trainer & TrainerRoad

Postby ab1959 » Thu Jan 31, 2019 8:23 am

Hi phil, did Elite ever react to your problem?

Return to “Direto & Direto X”

Who is online

Users browsing this forum: No registered users and 3 guests