Misuro b+ battery issue - device not responding

Moderators: Elite Admin S, Elite Admin M

mark_vandenbergh
Posts: 1
Joined: Mon Mar 30, 2020 10:38 am

Misuro b+ battery issue - device not responding

Postby mark_vandenbergh » Mon Mar 30, 2020 10:43 am

Hi all, bit of help required. I've recently got my trainer out to make the most of this lock down period. I haven't used it in over a year but all was working fine last time out.

I have the Qubo fluid and the misuro b+ device. I went to connect the misuro b+ but noticed no red light when pressing the button. I assumed it was probably the battery so I replaced it with a new one, the light came on, I set it to the number of flashes for my trainer and off I went to connect to zwift, which couldn't detect my device. I tried a couple of times and then thought to check the misuro b+ - no red light when I pressed the button, this seemed odd as it was a brand new battery. I went through the process with another brand new battery and the same thing happened. Any suggestions as to why this is happening? Am I missing something?

Thanks in advance
Mark

User avatar
Elite Admin S
Posts: 1750
Joined: Tue Nov 08, 2016 10:18 am

Re: Misuro b+ battery issue - device not responding

Postby Elite Admin S » Fri May 15, 2020 12:29 pm

Hi

If you use my e-training are you able to connect?
If not, it may be a malfunctioning of the misuro, contact our customer care at myetraining@elite-it.com

Regards


Return to “Misuro”

Who is online

Users browsing this forum: No registered users and 2 guests