Elite Qubo Smart Digital B+ loss of resistance

Drivo, Rampa, RealTour, RealAxiom, RealPower, Real Turbo Muin, Qubo Digital Smart B+

Moderators: Elite Admin S, Elite Admin M

rfollett38
Posts: 1
Joined: Wed Dec 20, 2017 11:43 pm

Elite Qubo Smart Digital B+ loss of resistance

Postby rfollett38 » Wed Dec 20, 2017 11:48 pm

Hello. I hope someone may be able to help.

I have been very happy with my Qubo Smart Digital B+ for nearly two years, using it mostly on Zwift but also with my Garmin and the E-Trainer app too. It has always been very good until yesterday morning, when for no apparent reason the resistance did not increase when going uphill. Instead Zwift displayed wildly high power outputs even though I was pedalling easily.

The same is true today and I have also tested it on the Garmin with the same effect (i.e. no change in resistance). This suggests it is not the software as it applies to more than 1 system.

I have deselected the wireless connection and then re-searched for it, reconnected etc, but there is no change.

Any help will be much appreciated.

Thanks.

Richard

User avatar
Elite Admin S
Posts: 618
Joined: Tue Nov 08, 2016 10:18 am

Re: Elite Qubo Smart Digital B+ loss of resistance

Postby Elite Admin S » Mon Jan 01, 2018 6:49 pm

It may be that the motor is stuck for some reason.
Please contact the customer care at real@elite-it.com, the guys there will give you the instructions to solve the problem

Regards


Return to “Interactive Trainers”

Who is online

Users browsing this forum: No registered users and 2 guests