Rampa, resistance too high

Moderators: Elite Admin S, Elite Admin M

Posts: 1
Joined: Tue Nov 21, 2017 7:33 pm

Rampa, resistance too high

Postby andrea.dentini » Tue Nov 21, 2017 7:47 pm

Hello, I just received my new Rampa trainer but I cannot use it at all. Pairing by Ant+FeC without any problem in Zwift, My-ETrainig, Veloreality, etc.
Trainer it is correctly paired with all apps and recognized as Rampa Ant-Fec, connection is ok and stable. The problem is the resistance that, no matter what app, is REALLY too high, I can barely pedal with my smallest ring, ok, I am not a pro but not up to this point. Another thing is that power reading it is stucked at 13 W also if I am pushing and sweating like climbin the Galibier. I tried everything at least twice, assy the unit, setting the clearance with wheel but nothing work. The only thing I have not tried yet is the calibration by Elite app because I do not have a power meter. In this moment the trainer it is not usable, even in flat Zwift course I cannot pedal. Please help me with this because I am stopped since yesterday and I really do not want to put the old trainer back.

User avatar
Elite Admin S
Posts: 1572
Joined: Tue Nov 08, 2016 10:18 am

Re: Rampa, resistance too high

Postby Elite Admin S » Fri Nov 24, 2017 11:40 am

Please contact our customer care at real@elite-it.com


Posts: 1
Joined: Tue May 15, 2018 10:49 am

Re: Rampa, resistance too high

Postby pogebaturalp » Tue May 15, 2018 10:51 am

any solutions for that topic as I have exactly the same problem.

I cannot even execute 100 watts with my trainer.

Hope to hear a solution.


Posts: 1
Joined: Sat Dec 01, 2018 1:01 am

Re: Rampa, resistance too high

Postby jezpond » Sat Dec 01, 2018 1:18 am

I'm having the same problem, I had been using my Rampa happily. Now since a calibration was run after changing the tyre it like trying to push a ton of lead up a mountain whilst going down a mountain. I can only manage to get 100watts max, normally I could easily sustain 220watts on the flat.

Please can you post up here what the solution is. Do I need to get the P numbers reset?

Return to “Rampa”

Who is online

Users browsing this forum: No registered users and 0 guests