Page 1 of 1

Zumo Calibration Failed

Posted: Mon Feb 25, 2019 2:08 am
by samuel.mundula
Hello, I did the procedure as listed (rode for >10 minutes) then went to the program on my laptop & went to the calibration menu. It asks me to start pedaling, then pedal faster, then stop pedaling until it spins down - then after the trainer spins down completely it says calibration failed.

Any ideas? Any way to calibrate this? Thanks

Re: Zumo Calibration Failed

Posted: Wed Feb 27, 2019 7:22 pm
I can verify that I have completed calibration twice on my Zumo using the iPhone app.

Both times were after rides of approximately one hour. Then I did the spin down calibration from advanced configuration in the app.

If you have an iPhone or Android you could try the app and see if the calibration works there.

Good luck!

Re: Zumo Calibration Failed

Posted: Tue Mar 05, 2019 7:06 pm
by natetg57
With my windows computer running Rouvy software, I had to try 4 or 5 times to get a successful calibration.

Re: Zumo Calibration Failed

Posted: Tue Mar 12, 2019 12:47 pm
by Elite Admin S
If calibration fails more time in a raw, contact our customer care at


Re: Zumo Calibration Failed

Posted: Tue Sep 10, 2019 10:37 am
by markcowell23
facing same issue :(

Re: Zumo Calibration Failed

Posted: Wed Nov 20, 2019 6:39 pm
by alexhall
I ran the upgrado app to get the latest firmware, ran the calibration test, it failed (several times) on both PC and Android App, now my resistance fluctuates between low and high in what seems a cycle. It seems that the whole thing is now fried as I ran a test ride in the myetraining app and achieved 3500 watts spinning a high gear at no resistance.