Page 1 of 1

Elite Quick Motion

Posted: Sat Oct 13, 2018 12:47 pm
by marko.novak
Question regarding Elite QM rollers...

I've ridden exactly 281 km on 16 rides on rollers.

On the last roller I've noticed difference in wear of the roller.
Because of the wear, last wheel on the bike is not stable when you ride.

The rollers are not near to the heat, neither are exposed to direct sunlight.

I am using a Vittora tyre for rollers/home trainer (red color).

Tyre pressure is 5 bar.

Has anyone else noticed the same thing?

Is roller replacable?

Any help is much appriciated.

Thanks.

Marko

Re: Elite Quick Motion

Posted: Thu Oct 18, 2018 12:59 pm
by Elite Admin S
Hi Marko

The normal use of Quick Motion shouldn't cause any wear to the drums.
We did lifetime tests of tens of thousands km without having this problem.

My hypothesis are these two:
- you have brake on the trainer; this indeed can cause a damage to the drum
- you are using a tire so soft that part of the rubber of the tire has seeped on the drum; in this case, cleaning the drums with some alcohol should solve the problem

Otherwise, please contact the customer care at myetraining@elite-it.com adding some photos of the drums so we can try to understand better the possible cause.

Regards

Re: Elite Quick Motion

Posted: Wed Oct 31, 2018 11:48 pm
by dwtrux@att.net
I now have over 2200 miles on my Quick Motion rollers over the last year or so. While both rear rollers have tire or rubber stains on the rear rollers (I call that the badge of effort) but no problems with stability.

Re: Elite Quick Motion

Posted: Thu Aug 15, 2019 5:54 am
by anncortez
Hello there did you get your speed sensor working

run 3

Re: Elite Quick Motion

Posted: Fri Aug 16, 2019 7:00 am
by mitchpegg
You explained in a detailed way. Nice to see this here. Thanks for sharing this to us. Want to know more about the private router details?> Here you will get 192.168.1.254 login details to use.